Author Topic: LUXAIRE Furnace  (Read 1490 times)

Offline jamie

  • 313D Supporter
  • ****
  • Posts: 23
LUXAIRE Furnace
« on: December 14, 2017, 11:16:54 PM »
Gentlemen,

LUXAIRE
m/TM9X080B12MP11A
S/ W1C0642185

   Ive had this Luxaire doing some funny things to me. Today it died...I think...it was locked out on 4 flashes which is limit switch open/open fuse.

It starts up, furnace lights, runs for a bit then shuts down, fan doesn't turn on at all. I hear a click, fan doesn't turn on, furnace locks out...I check voltage from Heat wire from board to fan, has 24V from board to fan (board has 24V going to this fan)..im assuming its almsot like a commnicating fan of some sort...fan does nothing. Fan on the ON setting on the stat, Fan doesn't turn at all. Is the fan just dead? There was no sign of burnt out or burning motor smell. Just happened tonight. Not sure if the board could do funny things like that but I figure if theres 24V going to fan and fan isn't turning on. its dead.. ANY other ideas?

and where would I get a motor for a LUXAIRE?? I am in durham Region
Thanks!

Offline Admin

  • Administrator
  • *****
  • Posts: 2361
    • HVAC TECH GROUP
Re: LUXAIRE Furnace
« Reply #1 on: December 15, 2017, 10:50:13 AM »
Is there 120V from the furnace board LINE terminal going to the fan motor?  It sounds like you're getting the 24V to the heating speed so it's likely the fan motor is bad.  You need to find a York dealer for that part, but they may not sell to the public.

The Master Group Mississauga
445, Admiral Blvd., Unit 10, Mississauga (Ontario), L5T 2N1
(905) 670-7521

I think the fan motor is part #S1-02435887000.