Poll

vent wont comes On when starting furnace after replacing ignitor/ pilot

vent not blocked
0 (0%)
safety on fail
0 (0%)

Total Members Voted: 0

Author Topic: furnace  (Read 2553 times)

Offline tozrin

  • ***
  • Posts: 4
furnace
« on: May 06, 2013, 09:58:30 AM »
vent wont comes On when starting furnace after replacing ignitor/ pilot on a keeprite upflow furnace

Offline Admin

  • Administrator
  • *****
  • Posts: 2363
    • HVAC TECH GROUP
Re: furnace
« Reply #1 on: May 06, 2013, 02:34:30 PM »
Are you refering to the main blower fan?

Do you have central AC?  Did you try switching the thermostat to fan ON?  Does the fan run?

There may be a faulty fan timer in that furnace or control board.

What's the model #?

Offline tozrin

  • ***
  • Posts: 4
Re: furnace
« Reply #2 on: May 10, 2013, 05:24:22 AM »
i m talking about exahust fan, , should'nt be  timer, as no place for it,. no AC in the unit..Thanks

Offline Admin

  • Administrator
  • *****
  • Posts: 2363
    • HVAC TECH GROUP
Re: furnace
« Reply #3 on: May 10, 2013, 06:10:38 AM »
It's probably the control board, unless you pulled the ventor motor wiring out of the molex connector when you replaced the ignitor.

Verify if you're getting 120V from the control board terminal that feeds the black wire to the ventor motor.

Offline tozrin

  • ***
  • Posts: 4
Re: furnace
« Reply #4 on: May 10, 2013, 08:13:43 AM »
ya the 120V going to the fannot stable/intermittent!..may the board as you mentioned,Thanks ADMIN..........

Offline Admin

  • Administrator
  • *****
  • Posts: 2363
    • HVAC TECH GROUP
Re: furnace
« Reply #5 on: May 10, 2013, 08:51:22 AM »
No problem!

Just make sure you have a constant 24V at the W terminal on the control board to rule out any possible low voltage wiring or thermostat problem.